思科利用三层交换机实现VLAN间路由

  • 内容
  • 评论
  • 相关

预备知识

VLAN的划分解决了广播域太大而容易引起广播风暴的问题,有利于增加网络带宽,提高带宽利用率。但划分了VLAN后,VLAN之间的计算机也不能通信,信息、资源不能共享,这与网络建立的目的相违背。

VLAN的划分把网络划分成多个逻辑网段,而不同网段之间的通信需要使用三层设备才能实现,路由器和三层交换机属于三层网络设备,均能实现不同网段之间的数据通信。三层交换机是在二层交换机的基础上添加了路由模块,同一VLAN的数据交换时通过交换模块完成,不同VLAN间数据交换才使用路由模块,因些三层交换机的交换数据速度要远远快于路由器,成为局域网连接不同网段间的首选设备。

实训目的

  • 了解二层交换机和三层交换机的区别。
  • 了解三层交换机VLAN接口的作用于。
  • 掌握VLAN间互通的配置思路及命令。

应用环境

某校园网的计算机设备都使用同一个网段进行管理,随着学校的发展计算机设备越来越多,由于同一网段的计算机过多,网络经常出现通信时断时续、甚至发生广播风暴导致网络瘫痪的情况。解决该问题的方法是对现有网络进行划分,把原来的大网段划分成二个或多个小的网段,再使用三层交换机实现不同网段之间的互通。

实训要求

  • 设备要求:
    1. 一台3560-24PS三层交换机、一台2950-24二层交换机和四台PC机。
    2. 一条交叉双绞线和四条直通双绞线。
  • 实训拓扑图
  • 1

  • 配置要求:

1)PC机配置要求:

2

2)交换机配置要求:

3

3)实训效果:所有PC机能互相PING通。

  • 实训步骤
  1. 添加设备后连接并设置各PC机IP信息。
  2. 二层交换机创建VLAN、接口加入VLAN、F0/24口。
  3. 三层交换机创建VLAN、设置三层VLAN接口IP、F0/24口设置为TRUNK。
  4. 测试所有PC机连通性。

详细步骤

1、添加设备使用双绞线按拓扑图连接网络。
2、按实训配置要求配置四台PC机的IP地址信息。
2、点击交换机S1进入命令行配置窗口,更改交换机名称、创建VLAN并把相应接口划入对应VLAN。

Switch>en            //进入特权用户配置模式
Switch#conf t       //进入全局配置模式
Switch(config)#hostname S1      //更改交换机名称
S1(config)#vlan 10              //创建编号为10的VLAN
S1(config-vlan)#exit            //退出VLAN配置模式
S1(config)#vlan 20              //创建编号为20的VLAN
S1(config-vlan)#exit            //退出VLAN配置模式
S1(config)#int range f0/1-2        //同时进入接F0/1到F0/2接口
S1(config-if-range)#switchport access vlan 10         // 把F0/1到F0/2划入VLAN 10
S1(config-if-range)#exit      //退出接口配置模式
S1(config)#int range f0/3-4        //同时进入接F0/3到F0/4接口
S1(config-if-range)#switchport access vlan 20        //把F0/3到F0/4接口划入VLAN 20
S1(config-if-range)#

4、进入F0/24接口,设置接口模式为TRUNK模式。

S1(config-if-range)#exit             //退出接口配置模式
S1(config)#int f0/24            //进入F0/24接口
S1(config-if)#switchport mode trunk        //把接口模式配置为trunk模式
S1(config-if)#

5、保存二层交换机S1的配置。

S1(config-if)#^Z          //按“Ctr+Z”键退出到特权模式
S1#write        //保存配置
Building configuration...
[OK]
S1#

6、进入三层交换机S2,更改交换机名称并进入F0/24接口封装dot1q协议并设置为TRUNK模式。


Switch>en            //进入特权用户配置模式
Switch#conf t       //进入全局配置模式
Switch(config)#hostname S2      //更改交换机名称
Switch(config)#ip routing       //启动路由
S2(config)#int f0/24            //进入F0/24接口
S2(config-if)#switchport trunk encapsulation dot1q     //为F0/24接口封装dot1q协议
S2(config-if)#switchport mode trunk        //把接口模式配置为trunk模式
S2(config-if)#exit         //退出接口配置模式
S2(config)#

7、创建VLAN10、VLAN20后分别进入VLAN10和VLAN20的三层接口配置IP地址。

S2(config)#vlan 10              //创建编号为10的VLAN
S2(config-vlan)#exit     //退出vlan配置模式
S2(config)#vlan 20              //创建编号为20的VLAN
S2(config-vlan)#exit     //退出VLAN配置模式
S2(config)#interface vlan 10              //进入vlan 10接口配置模式
S2(config-if)#ip address 192.168.1.254 255.255.255.0     //设置IP地址
S2(config-if)#no shut          //打开接口
S2(config-if)#exit         //退出接口配置模式
S2(config)#interface vlan 20              //进入vlan 20接口配置模式
S2(config-if)#ip address 192.168.2.254 255.255.255.0     //设置IP地址
S2(config-if)#no shut          //打开接口
S2(config-if)#

8、使用PC1 PING其它PC机,所有计算机都能连通,如下所示。

PC>ping 192.168.1.2 //与PC2连通
Pinging 192.168.1.2 with 32 bytes of data:
Reply from 192.168.1.2: bytes=32 time=62ms TTL=128
Reply from 192.168.1.2: bytes=32 time=47ms TTL=128
Reply from 192.168.1.2: bytes=32 time=62ms TTL=128
Reply from 192.168.1.2: bytes=32 time=62ms TTL=128
Ping statistics for 192.168.1.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 47ms, Maximum = 62ms, Average = 58ms
……
PC>ping 192.168.2.1 //与PC3连通
Pinging 192.168.2.1 with 32 bytes of data:
Reply from 192.168.2.1: bytes=32 time=109ms TTL=127
Reply from 192.168.2.1: bytes=32 time=125ms TTL=127
Reply from 192.168.2.1: bytes=32 time=125ms TTL=127
Reply from 192.168.2.1: bytes=32 time=125ms TTL=127
Ping statistics for 192.168.2.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 109ms, Maximum = 125ms, Average = 121ms
……
PC>ping 192.168.2.2 //与PC4连通
Pinging 192.168.2.2 with 32 bytes of data:
Reply from 192.168.2.2: bytes=32 time=94ms TTL=127
Reply from 192.168.2.2: bytes=32 time=125ms TTL=127
Reply from 192.168.2.2: bytes=32 time=125ms TTL=127
Reply from 192.168.2.2: bytes=32 time=125ms TTL=127
Ping statistics for 192.168.2.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 94ms, Maximum = 125ms, Average = 117ms
PC>
  • 相关命令

4

  • 相关知识
  1. VLAN间通信除用到本实训用到的三层交换机外,还能用路由器实现,路由器通过把单个接口划分成多个子接口,每个子接口封装dot1q协议,对应相应的VLAN实现不同网段通信。
  2. 思科三层交换机端口默认TRUNK封装为“auto”模式,只有重新使用命令“switchport trunk encapsulation dot1q”封装为dot1q(vlan协议)才能使用命令“switchport mode trunk”更改端口为trunk模式。
  • 注意事项
  1. 思科大多数交换机设备TRUNK口支持VLAN需要先封装dot1q协议,否则不能成功设置端口为TRUNK口,如本实训中的3560交换机。
  2. 计算机需要设置本网段的网关,否则不能连通其余网段的设备。

练习

根据实训拓扑图完成下更练习,完成后所有计算机能互通。
5

评论

0条评论

发表评论

电子邮件地址不会被公开。 必填项已用*标注